

Seu próximo nível começa aqui
Seu desenvolvimento não pode ter limites. Garanta sua Assinatura Ilimitada e libere uma preparação completa com os melhores professores do Brasil.
O protocolo HTTP define um conjunto de métodos de requisição responsáveis por indicar a ação a ser executada para um dado recurso. Sobre esse protocolo, segundo Kurose (2021), pode se afirmar que:
o HTTP/2 altera os métodos, códigos de status, URL e campos do cabeçalho do HTTP, transformando-o em um protocolo mais robusto quanto à segurança.
o serviço oferecido pelo TCP garante que toda mensagem de requisição HTTP emitida por um processo cliente chegue intacta ao servidor, mas o retorno não tem a mesma garantida de integridade por conta das possíveis interferências do meio adjacente.
para fins de segurança, o HTTP mantém informações sobre os clientes que fazem as requisições, essa configuração é conhecida por comunicação persistente e pode ser configurada independentemente da aplicação.
nas especificações do HTTP (RFC 1945; RFC 7230; RFC 7540), a linha de requisição tem quatro campos: o do método, o do protocolo de transporte, o do URL e o da versão do HTTP.
o mecanismo de GET condicional permite que um cache verifique se seus objetos estão atualizados, auxiliando no tempo de resposta do sistema.