Questões de Concurso sobre HTTP (HYPER TEXT TRANSFER PROTOCOL)

 
 
Disciplina
Assunto 1
Banca
Instituição
Cargo
Ano
Carreira
Área de formação
Escolaridade
Dificuldade
 
Comentários:
Professores
Alunos
Meus Comentários
Vídeo
 
Minhas questões:
Resolvidas
Não resolvidas
Certas
Erradas
 
Tipo de questão:
Certo e errado
Múltipla escolha
Incluir questões:
Anuladas
Desatualizadas
 
Questões:
Todas as questões
 
Filtro simplificado
 
Questões
Todas as questões
 
307 questões encontradas
Questões por página
20
Mais recentes
 

Marque a alternativa correta sobre a resposta de uma requisição HTTP.


A

Os códigos iniciados em 2 indicam que a operação não foi bem sucedida.


B

O campo MIME-Type indica o tipo de dados transportados, que podem ser, por exemplo: HTML, XML, JSON, etc.


C

O campo Content-Type indica o tipo de dados transportados, que podem ser, por exemplo: HTML, XML, JSON, etc.


D

O campo Content-Type indica o tipo de dados transportados, que podem ser, por exemplo: GET, POST, DELETE, etc.

Assinale a que apresenta apenas métodos HTTP válidos:


A

UPDATE, POST, GET, INFO


B

POST, GET, INFO, FIND


C

POST,PUT, GET, RESULT


D

GET, REMOVE, FIND, POST


E

PUT, POST,GET,DELETE, PATCH

A navegação na internet é realizada basicamente por meio do protocolo HTTP – HyperText Transfer Protocol, que define como os clientes e servidores web irão trocar mensagens (requisições e respostas). Considere um usuário que realiza o envio de informações preenchidas em um formulário HTML através de uma requisição HTTP POST para o servidor. Ao processar a requisição, o servidor web encontra a página do endereço de destino e um script PHP é disparado; ele executa uma operação matemática de divisão por zero. Neste caso, qual o status código da resposta HTTP será devolvido pelo servidor web?


A

200


B

403


C

404


D

500

Considere a requisição realizada para a URL http:// www.google.com/search?q=HTTP+request a partir de um navegador web e analise as afirmativas a seguir, considerando como contexto o protocolo HTTP.


I. A requisição foi realizada pela porta 80.

II. Foi enviado um parâmetro na requisição, via query string.

III. O servidor é identificado pelo nome www.google. com.


Está(ão) correta(s) a(s) afirmativa(s)


A

I, apenas.


B

I e II, apenas.


C

I e III, apenas.


D

II e III, apenas.


E

I, II e III.

O HTTP é um protocolo da camada de aplicação e é executado em dois programas, sendo um deles o cliente e o outro o servidor. Ele possui o papel de definir como são as trocas de mensagens entre cliente e servidor. Ele usa o protocolo TCP da camada de transporte e não o UDP.


C

Certo


E

Errado

Sobre as arquiteturas e protocolos em redes Internet Protocol (IP), é correto afirmar que:


A

o protocolo ICMP é um protocolo de camada de aplicação que tem como função realizar testes de conectividade entre dispositivos.


B

o protocolo HTTP é um protocolo de camada de aplicação sem controle de estados (stateless).


C

o protocolo de camada de transporte UDP é orientado à conexão, enquanto o protocolo TCP não é orientado à conexão.


D

o protocolo FTP utiliza o mecanismo de autenticação disponível no protocolo de camada de transporte UDP.

Um usuário está relatando que o seu navegador apresenta o seguinte código de erro ao tentar acessar uma página inicial de um site na intranet:


HTTP Error 403 – Forbidden


O navegador utilizado pelo usuário está na lista de softwares homologados para uso na rede da empresa. Antes de uma análise aprofundada e apenas com essas informações, a conclusão mais provável é que


A

o usuário não tem permissão para navegar na intranet.


B

o usuário não tem permissão para navegar na internet.


C

o servidor HTTP está indisponível.


D

o servidor HTTP está com uma sobrecarga.


E

deve haver erros de configuração de permissões no servidor HTTP.

"O protocolo HTTP define um conjunto de métodos de requisição responsáveis por indicar a ação a ser executada um dado recurso. Embora métodos possam ser descritos como substantivos, eles também são comumente referenciados como HTTPVerbs (Verbos HTTP). Cada um deles implementa semântica diferente". Em relação aos verbos HTTP, são verdadeiras as afirmações:


l - O método GET é utilizado para submeter uma entidade a um recurso específico, frequentemente causando uma mudança no estado do recurso ou efeitos colaterais no servidor.

II - O método POST solicita a representação de um recurso específico. Requisições utilizando o método POST devem retornar apenas dados.

lIl - O PUT substitui todas as representações do recurso de destino pela carga de dados da requisição.

IV - O método DELETE remove um recurso específico.


A

Somente as l e II


B

Todas são verdadeiras


C

Somente as l, II e IV


D

Somente as III e IV


E

Somente as II, III e IV

O protocolo HTTP aceita determinados métodos internos de solicitações. Assinale a alternativa que NÃO representa um método válido.


A

HEAD.


B

DELETE.


C

META.


D

TRACE.


E

OPTIONS.

O protocolo HTTP define um conjunto de métodos de requisição responsáveis por indicar a ação a ser executada para um dado recurso. Sobre esse protocolo, segundo Kurose (2021), pode se afirmar que:


A

o HTTP/2 altera os métodos, códigos de status, URL e campos do cabeçalho do HTTP, transformando-o em um protocolo mais robusto quanto à segurança.


B

o serviço oferecido pelo TCP garante que toda mensagem de requisição HTTP emitida por um processo cliente chegue intacta ao servidor, mas o retorno não tem a mesma garantida de integridade por conta das possíveis interferências do meio adjacente.


C

para fins de segurança, o HTTP mantém informações sobre os clientes que fazem as requisições, essa configuração é conhecida por comunicação persistente e pode ser configurada independentemente da aplicação.


D

nas especificações do HTTP (RFC 1945; RFC 7230; RFC 7540), a linha de requisição tem quatro campos: o do método, o do protocolo de transporte, o do URL e o da versão do HTTP.


E

o mecanismo de GET condicional permite que um cache verifique se seus objetos estão atualizados, auxiliando no tempo de resposta do sistema.

O principal protocolo de comunicação responsável tanto pelos formatos quanto pelas regras de troca de dados e mensagens entre computadores de uma ou várias redes conectadas à internet é o protocolo:


A

FHC.


B

FPS.


C

IP.


D

TCP.


E

HTTP.

Um dos protocolos mais usados atualmente em redes de computadores é o HTTP. Em que camada de rede da arquitetura TCP/IP esse protocolo se localiza?


A

Aplicação


B

Transporte


C

Rede


D

Comunicação


E

Física

Em muitas aplicações da Internet, o cliente e o servidor se comunicam por um período prolongado de tempo, em que o cliente faz uma série de requisições e o servidor responde a cada uma. As conexões HTTP que utilizam o TCP podem ser:


A

exclusivamente persistentes.


B

exclusivamente não persistentes.


C

persistentes e não persistentes.


D

temporais.


E

não temporais.

Um protocolo de transferência possibilita que ao inserir a URL do seu site na Web seja possível ver os conteúdos e dados que nele existem. Esse sistema é a base da comunicação que existe em toda a Internet em que os sites e conteúdos que tragam hiperlinks possam ser encontrados mais facilmente pelo público por meio de um clique do mouse ou um toque na tela. Estamos nos referindo ao protocolo denominado:


A

XML.


B

HTTP.


C

DHTML.


D

PHP.


E

Javascript.

HTTP e HTTPS são protocolos criados para especificar a comunicação entre navegador e servidor web. Sabendo disso, a afirmação abaixo verdadeira é:


A

ambos possuem o mesmo nível de segurança, com diferença de pequenas atualizações entre eles.


B

a diferença entre os protocolos fica na segurança que ambos provêm. O HTTPS implementa uma camada a mais em relação ao tradicional HTTP, que provê segurança no tráfego de dados sensíveis.


C

nenhum dos dois protocolos implementa uma camada segura de comunicação entre navegador e servidor.


D

a diferença entre os protocolos fica na segurança que ambos provêm. O HTTP implementa uma camada a mais em relação ao HTTPS, que provê segurança no tráfego de dados sensíveis.

   
Gerar simulado